Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 12:26 BST
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Jul 24, 2020 - 12:19 BST
This incident affected: Issue Checklist Free.