Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 15:57 BST
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Sep 30, 2020 - 15:51 BST
This incident affected: Issue Checklist Pro.