Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 09:11 BST
Update
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Jul 20, 2020 - 13:50 BST
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Jul 20, 2020 - 13:41 BST
This incident affected: Issue Checklist Free.