Jira displays error We're having trouble connecting to Clockwork...
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 15:35 BST
Monitoring
A few customers reported that cleaning Jira related local storage/cookies/logging in again the browser solved the problem.

Please contact us if the workaround doesn't work for you.

Other vendors are affected as well as this is a bug in Atlassian Connect Framework, the issue is tracked as https://ecosystem.atlassian.net/browse/ACJS-1134
Posted Aug 07, 2020 - 16:50 BST
Investigating
A few customers reported that Jira instead of showing Clockwork pages displays an error message starting with "We're having trouble connecting to Clockwork..."
Posted Jul 28, 2020 - 10:35 BST
This incident affected: Clockwork Automated Timesheets (Clockwork Pro and Free).