Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 15:13 BST
Update
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Sep 28, 2020 - 14:58 BST
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Sep 28, 2020 - 14:50 BST
This incident affected: Issue Checklist Free.