Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 18:22 BST
Update
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Apr 01, 2021 - 18:00 BST
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Apr 01, 2021 - 17:59 BST
This incident affected: Issue Checklist Free.