Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 13:25 BST
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Jun 02, 2021 - 13:24 BST
This incident affected: Issue Checklist Pro.