Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 10:59 BST
Update
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Mar 29, 2021 - 10:42 BST
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Mar 29, 2021 - 10:41 BST
This incident affected: Checklist (Issue Checklist Pro).