Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Nov 13, 2020 - 07:54 GMT
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Nov 13, 2020 - 07:52 GMT
This incident affected: Checklist (Issue Checklist Pro).