Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 08:57 GMT
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Jan 13, 2021 - 08:56 GMT
This incident affected: Checklist (Issue Checklist Pro).