Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Feb 11, 2021 - 05:15 GMT
Update
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Feb 11, 2021 - 05:10 GMT
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Feb 11, 2021 - 05:02 GMT
This incident affected: Issue Checklist Free.