Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 10:03 BST
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Jul 24, 2020 - 10:01 BST
This incident affected: Issue Checklist Pro.