Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jun 12, 2020 - 20:04 BST
Update
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Jun 12, 2020 - 19:58 BST
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Jun 12, 2020 - 19:43 BST
This incident affected: Issue Checklist Pro.