Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jun 27, 2020 - 18:09 BST
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Jun 27, 2020 - 18:05 BST
This incident affected: Issue Checklist Free.