Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
We have resolved the problem with Issue Checklist Pro. It's now fully operational again.
Posted Jun 08, 2024 - 10:27 BST
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Jun 08, 2024 - 10:22 BST
This incident affected: Checklist (Issue Checklist Pro).