Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Nov 11, 2020 - 01:43 GMT
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Nov 11, 2020 - 01:42 GMT
This incident affected: Issue Checklist Free.