Degraded performance in Clockwork

Incident Report for HeroCoders

Resolved

A fix has been implemented on Heroku side, and all app functionalities have been fully restored.
Posted Jun 11, 2025 - 06:43 BST

Identified

Based on the update from Heroku, the Investigation is ongoing, and a permanent fix is in progress.
Posted Jun 10, 2025 - 18:01 BST

Investigating

Our provider, Heroku, is currently experiencing a service outage, which affects access to the Clockwork app.
It is currently being investigated by our teams.
Posted Jun 10, 2025 - 13:19 BST
This incident affected: Clockwork Automated Timesheets (Clockwork Pro and Lite).