Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
We have resolved the problem with Issue Checklist Free. It's now fully operational again.
Posted Sep 21, 2024 - 00:55 BST
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Sep 21, 2024 - 00:36 BST
This incident affected: Checklist (Issue Checklist Free).