Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Nov 13, 2020 - 08:52 GMT
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted Nov 13, 2020 - 08:51 GMT
This incident affected: Issue Checklist Pro.