Slower response (Issue Checklist Free)

Incident Report for HeroCoders

Resolved

We have resolved the problem with Issue Checklist Free. It's now fully operational again.
Posted Mar 12, 2025 - 14:18 GMT

Investigating

Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Mar 12, 2025 - 14:17 GMT
This incident affected: Checklist (Issue Checklist Free).