Clockwork - Degraded performance

Incident Report for HeroCoders

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 16:05 GMT

Investigating

We've noticed problems related to loading timers and worklogs.

Our developers are investigating this.
Posted Feb 05, 2026 - 14:03 GMT
This incident affected: Clockwork Automated Timesheets (Clockwork Pro and Lite).