Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Mar 18, 2021 - 00:42 GMT
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Mar 18, 2021 - 00:41 GMT
This incident affected: Issue Checklist Free.