Clockwork pages are not loading, some actions are failing
Incident Report for HeroCoders
Resolved
Those incidents were caused by random memory spikes causing our app to cross the platform limits. We switched to jemalloc and since then we observe improved stability and decreased memory usage.
Posted Jan 14, 2021 - 09:43 GMT
Monitoring
We've deployed a fix and are monitoring results. So far the system has been stable.
Posted Dec 30, 2020 - 15:43 GMT
Investigating
Since yesterday we have some stability problems and we are working hard to identify the root cause.

Occasionally some of our web servers are becoming unresponsive or take a long time to process requests making random requests fail.
Posted Dec 30, 2020 - 10:24 GMT
This incident affected: Clockwork Automated Timesheets (Clockwork Pro and Free).