Clockwork Outage
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Mar 14, 2023 - 08:53 GMT
Update
We are continuing to investigate this issue.
Posted Mar 14, 2023 - 08:51 GMT
Investigating
Clockwork is responding slower than usual and we are currently looking into the issue.
Posted Mar 14, 2023 - 08:10 GMT
This incident affected: Clockwork Automated Timesheets (Clockwork Pro and Free).