Slower response (Issue Checklist Pro)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted May 13, 2023 - 14:02 BST
Investigating
Issue Checklist Pro is responding slower than usual and we are currently looking into the issue.
Posted May 13, 2023 - 14:01 BST
This incident affected: Checklist (Issue Checklist Pro).