Slower response (Issue Checklist Free)
Incident Report for HeroCoders
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 10:15 GMT
Update
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Jan 13, 2021 - 09:59 GMT
Investigating
Issue Checklist Free is responding slower than usual and we are currently looking into the issue.
Posted Jan 13, 2021 - 09:59 GMT
This incident affected: Checklist (Issue Checklist Free).